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Description 
 

The Epygi Auto Dialer is a licensable feature that enables all Epygi IP PBXs to perform immediate or 
scheduled dialing to phone numbers from a calling list, with the option of playing one or more voice 
files and a voice menu.   

The Auto Dialer can prompt the called party to enter a response by pressing one or more DTMF 
keys to navigate options.  The responses entered are then updated in the calling list. The feature is 
implemented as a MS Windows TM application.  

The calling list that is used and updated by the Auto Dialer can be uploaded from a list of names 
and contact numbers that are stored in an MS Excel TM file.  The contact numbers can also be 
manually entered from within the Auto Dialer’s calling list screen.   

Please Note:  Auto Dialer does not require the additional 3pcc license to be installed on the Epygi 
IP PBX. 

There is no limitation on the number of Auto Dialers that can be connected to the same IP PBX 
unit. The only limitation is there is a maximum number of concurrent calls originated by all 
connected Auto Dialers; it cannot exceed the total number specified in the Auto Dialer feature keys 
installed on the IP PBX unit. 

 

Market 
 

The Auto Dialer’s target markets are small doctors’ offices, independent pharmacies and other 
service providers that call their customers on a daily basis as part of their operating procedures. 
Some of the usage scenarios are as follows: 

Doctor offices – A doctor’s office calls their patients on a daily basis to confirm appointments for 
the week and to minimize no-show appointments, which cost the doctor time and money. Doctors 
do this manually by using the front office staff to place the calls. Many times they have to call more 
than once if there is no answer, voice mail is encountered or the wrong person answers. In some 
cases, the patient needs to reschedule their appointment time and contact the doctor’s office 
directly. 
 
Small local pharmacies – Large pharmacy chains have very expensive phone systems, tied to 
their ERP systems that perform automated calling to alert patients when their prescriptions are 
ready. These systems also allow patients to call into the IVR and automatically refill prescriptions 
by entering their specific prescription number using the phone keypad. These systems are not 
always affordable, especially for small, independent pharmacies which have to rely on staff for 
customer calls notifying them when prescriptions are filled and ready to be picked up. 
 
Telemarketing – Telemarketers prepare recorded promotions based on a customer database and 
place calls to the selected customers which allow them to talk to an agent or opt out.  
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Installation 
 

Before installing Epygi Auto Dialer, go to the System -> Features on the Quadro GUI to make 
sure the Auto Dialer Support feature is activated.  

Please Note: Auto Dialer does not require the additional 3pcc license to be installed on the Epygi 
IP PBX. 

The following is required for the proper operation of the Epygi Auto Dialer: 

• Min required space on PC – 8 MB 

• MS Windows XP, MS Windows 7, MS Windows Vista. MS Windows servers 2003 and 2008 

• Microsoft .NET Framework 3.5 

• Network connection to the Quadro IP PBX 

• The Quadro IP PBX and the host where the Epygi Auto Dialer is running should be visible 
to each other. 

To install, run the setup files for Epygi Auto Dialer and follow the instructions of the setup wizards 
until the end. For information on how to activate and configure the Auto Dialer feature on the 
Quadro IP PBX, see the Administrator’s Manual for the Quadro. 

To upgrade from an existing version, close the Auto Dialer and run the setup wizard for the new 
version.  The configuration and the data will remain after the upgrade. It is not necessary to 
uninstall the previous version before performing the upgrade. 

 

Configuration 
 

Before starting the calling session, you must configure the following items for the Auto Dialer:  

• The connection and call-related parameters in the Options window 
• Calling scenario – this specifies the Auto Dialer’s actions to be taken before and after the 

called party has entered their response on the phone’s keypad.  
• Calling list – a list of phone numbers to call along with the corresponding supplementary 

information (like day of the week, time, etc.) to be used by the Auto Dialer for automatic 
generation of voice messages to be played to the called party. The calling list can be 
created by tools like MS ExcelTM and saved in CSV format. 

Please Note: At the time of configuring the calling scenario, all voice messages and voice menus 
(for details see below) need to be pre-recorded and placed in the same folder, accessible for Auto 
Dialer. 

 

Configuring Connection with Epygi IP PBX 

 

Each time the Auto Dialer starts, it opens the Options window, where the user must configure in 
the Connection Tab the parameters used to connect to the Epygi IP PBX. The same window can 
be opened after the Auto Dialer starts by selecting the Tools -> Options menu item or 
corresponding icon in the toolbar. The input fields in the Options window are as follows (see the 
example on Figure 1): 
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• Host is the IP address of the Epygi IP PBX 
used by Auto Dialer for making the calls. 

• Port is the 3pcc port of Epygi IP PBX. For 
details on how to configure this port on the 
Epygi IP PBX, see the IP PBX manual. The 
default value of the 3pcc port on all Epygi IP 
PBX products is 4849. 

• UserName is either “admin”, “localadmin” 
or an extension number on Epygi IP PBX. If 
“admin” or “localadmin” is entered for 
UserName, the Auto Dialer will make the 
calls on behalf of the system Auto 
Attendant. Otherwise, the calls will be made 
on behalf of the extension entered in this 
field. This value also determines the storage 
for voice messages used by Auto Dialer 
during the calls. Before starting the calls, 
the Auto Dialer uploads all needed voice files 
to the IP PBX - to the memory space for the 
extension indicated in the UserName field.  
In case of “admin” or “localadmin” the 
uploaded voice files will be stored in the 
system Auto Attendant’s memory. Additional 
memory may need to be allocated to the AA 
or extension memory settings to 
accommodate the voice files. When the 
required memory exceeds, the oldest entries 
with “dial_” prefix are being automatically 
deleted. 

 

 
Figure 1 

• Password is either the admin’s or localadmin’s “Phone Access Password” or the extension’s 
password. 

• Secure Connection checkbox allows to establish a secure connection with Epygi IP PBX if 
appropriate checkbox is set in Epygi IP PBX 3PCC settings. 

The Connection tab field values can be changed only when the Auto Dialer is disconnected from 
the IP PBX. 

The Calls Tab of the Options window allows the user to configure the following call-related 
parameters (see the example on Figure 2): 
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No input timeout: this is the period of time 
during which Auto Dialer waits for the called 
party’s input after playing the voice menu. If 
there is no input during that period, the call is 
considered to have failed and Auto Dialer 
will make another call attempt to the same 
number. 

Max number of simultaneous calls: This 
specifies the maximum number of concurrent 
calls that Auto Dialer is allowed to make. If 
this number is more than the total of the 
feature license keys installed on Epygi IP PBX 
then the max number of the concurrent calls 
will be limited to the licensed calls.  

Max retry count: If the call to a particular 
phone number fails because it was busy, not 
connected (network failure), not answered or 
answered without called party’s input (No 
input timeout expired), the Auto Dialer will 
make repetitive call attempts to that phone 
number until either: 

• the number of failed attempts equals 
Max retry count or, 

• the call is answered by the called party 
and the confirmation input is received. 

 

 
Figure 2 

 

Time between repeated attempts: This specifies the minimum amount of time between the Auto 
Dialer’s subsequent call attempts to the same phone number after the failed attempt.  

Schedule start time: Auto Dialer will start the calling session either immediately by the Start 
command, or at the scheduled time, when the Start by schedule command is used. This 
parameter specifies the time of the day when the calling session will start by the Start by 
schedule button command. For details on how to use these commands, see below. 

Schedule end time: This specifies the time of the day when the active calling session will stop 
after being activated by Start by schedule command. The calling session will not stop at the 
scheduled end time if the session was been activated by the Start. 

 

The Calls tab field can be changed only when the calling session is not active. 
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The Date Time Tab of the Options window 
allows the user to specify the Date and 
Time formats settings for France and USA 
and to play records according to the selected 
format (see the example on Figure 3): 

 

 

 
Figure 3 

 

 

Configuring the Calling Scenario 

 

The calling scenario is a sequence of actions executed by Auto Dialer for every contact in the 
Calling List. Before starting the calling session, the user will either create a new scenario or open a 
saved scenario from a previous calling session.  

 

Creating a New Calling Scenario 

 

To create a new scenario, open the scenario page selecting the View -> Scenario menu item or 
Scenario tab in the toolbar (see an example of the scenario page on the Figure 4). 
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Figure 4 

The scenario may consist of one or more actions. The possible actions are: 

 

• Call to:  
• Play message: 
• Play menu: 
• Play date: 
• Play time 
• Play number  

 

To select the desired action, press the action button on the scenario page (see an example on 
Figure 5). 
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Figure 5 

call to action 

The call to action is always the first action in the scenario. Each scenario only allows one call to 
action. The call to action will tell the Epygi IP PBX to make a call to the phone number retrieved 
from the current position (line) in the calling list.  

All phone numbers should be stored in the same column from the Calling List.  This column should 
have a heading name that will be automatically pulled from the Action Input field next to the call 
to action.  In the calling list example on Figure 6, the phone numbers are stored in the “Phones” 
column and therefore, “Phones” needs to be selected from the drop down list of column names 
when pressing the Action Input button next to the call to action (see Figure 6). 

 

 
Figure 6 
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Figure 7 

 

Play message action 

 

The play message action is used for playing a prerecorded voice message to the called party 
when the call is answered. The name of the voice message file should start with the "dial_" 
prefix, otherwise the file will be rejected by the Auto Dialer Application. The user selects the voice 
message file to be played by pressing the Action Input button and browsing for the folder that 
contains the voice file. In the example on Figure 8 the “dial_welcome.wav” file is selected for play 
out during the play message action. 

 

                        
Figure 8 
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During the play message action, when the voice message is being played to the called party, the 
Auto Dialer will not react to DTMF tones received from the called party. If the play message 
action is the only action in the scenario that is listed after the call to action, then after playing the 
voice message, the call will be disconnected. 

 

Play date action 

 

The play date action is used for playing an automatically generated voice message with the date 
and day of the week to the called party. 

All dates should be stored in the same column from the calling list. This column should have a 
heading name that will be automatically pulled from the Action Input field next to the play date 
action. In the calling list example on Figure 6, the dates are stored in the “Date” column and 
therefore, “Date” needs to be selected from   the drop down list of column names when pressing 
the Action Input button next to the play date action (see Figure 9). 

 

 
Figure 9 

 

Play time action 

 

The play time action is used for playing an automatically generated voice message with the time 
of day to the called party. 

All times should be stored in the same column from the calling list. This column should have a 
heading name that will be automatically pulled from the Action Input field next to the play time 
action.  In the calling list example on Figure 6, the times are stored in the “Time” column and 
therefore, “Time” needs to be selected from the drop down list of column names when pressing 
the Action Input button next to the play time action (see Figure 10). 
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Figure 10 

 

Play number action 

 

The play number is used for playing an automatically generated voice message representing a 
number to the called party. 

All numbers should be stored in the same column from the calling list. This column should have a 
heading name that will be automatically pulled from the Action Input field next to the play 
number. 

The play number action can be used to play a message to the called party when numbers are 
required. For example, a message that says, “Your ticket number is, 123456”.  

 

Play menu action 

 

The play menu action works in two steps.  The first step is to play a pre-recorded message to the 
called party requesting the person to respond by pressing a key on their phone.  The name of the 
voice message file should start with the "dial_" prefix, otherwise the file will be rejected by the 
Auto Dialer Application and the corresponding warning will be displayed. The Auto Dialer will 
then wait for the person to enter their response.  

The pre-recorded message to be played is selected by pressing the Action Input button (next to 
play menu action) and browsing to the folder that contains the voice file. In the example on 
Figure 11 the “dial_invite.wav” file is selected for play out during the play menu action. 

The valid user inputs and actions of the play menu action are configured in the Menu window 
which opens when the user selects the play menu action (see the example on Figure 11). 
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Figure 11 

Each item (line) of the Menu defines the final action that will be performed by Auto Dialer in 
response to called party’s input. 

The first field of the Menu line – User Input, defines the called party’s input; the possible 
options are DTMF digits 0, 1, 2, … 9, * and #. The user can enter the DTMF digits at any point 
when a message is being played. 

The second field of the Menu line – Status, defines the status of the call after the called party’s 
input.  The possible options are: “confirmed”, “cancelled” and “transferred”. If, like the example in 
Figure 11, the user presses 1, the call status will be set to “confirmed” and considered a positive 
reply from the user. The status will be displayed in the calling list in real time and the Auto Dialer 
will not call that phone number again during the calling session. If the user presses 2, the call 
status will be set to “cancelled” and considered a negative reply from the user. The status will be 
displayed in the calling list and the Auto Dialer will attempt to call that phone number again. If 
“cancel” is selected, the Auto Dialer will close the call immediately, ignoring all subsequent actions 
in the scenario following the play menu action. An example of the cancel option might be used if 
the wrong person was contacted, the user would press option 2. In the same example on Figure 
11, if the user presses 3 then the call will be transferred to extension 110 - the phone number 
specified in the Connect To field of the Menu line. 

The third field of the Menu line – Response text, specifies the text to be written into a column of 
the calling list after the user’s input. The next field – Response column, specifies the column 
heading of the calling list where the above mentioned text will be written.  

For example on Figure 11, if the user pressed 1, then the status of the call will be changed to 
“confirmed” and “Yes” will be the actual text written into the “Response” column of the calling list. 

The last field of the Menu line – Connect To specifies the phone number to transfer the call to 
after the user’s input. For example on Figure 11, if the user pressed 3 then the call will be 
transferred to extension 110. Any kind of phone number can be used in this field –it just needs to 
be in accordance with the call routing rules of the Epygi IP PBX connected to the Auto Dialer. For 
example, it can be an extension number, PSTN number, SIP number or ACD group number.  

The above mentioned Menu item allows a lot of flexibility to create very simple or very complex 
scenarios by assigning different actions and response texts to different user inputs.  

 

The “Play menu message [n] times until the user input or timeout” setting in the Menu window is 
used to repeat the message that will be played to the called party.  This field is significant if the 
Auto Dialer will be calling out on a PSTN POTS line using one of the Quadro FXO ports. As a usage 
note, it is suggested to keep the very first greeting message that is played to the called party as 
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short as possible and recorded so that the user can listen to any part of the message and 
understand the intent.  Calls placed on an FXO port do not receive answer supervision from the 
Central Office so the Quadro cannot start the message from the beginning when the caller actually 
answers and says, “Hello”. Depending on when the called party answers, the first part of the 
message may have already been played. Therefore, with this option, the Auto Dialer can be 
configured to repeat this message so that it can be heard in its entirety. 

 

 

Opening the Existing Calling Scenario 

 

The created scenario can be saved by selecting the File -> Save or Save As menu command or 
with the corresponding icon on the toolbar. When saving a scenario, the Scenario tab needs to be 
visible in the Auto Dialer’s window. The scenario file will be saved in XML format. 

To open the existing scenario, select File -> Open -> Scenario or click the corresponding icon 
on the toolbar. The opened scenario can be modified and saved for future usage. 

 

Building the Calling List 

 

The best way to create the calling list is by using MS ExcelTM and saving it in CSV format. The 
saved file can be opened by the Auto Dialer and used as a Calling List if it meets the requirements 
discussed below. An example of a calling list imported from a CSV file is presented in Figure 6. 

The Excel sheet used as a calling list may have any number of columns but only a few of them are 
required for use by the Auto Dialer.  

The main mandatory column is the column containing the phone numbers. The phone numbers in 
this column need to be in accordance with the call routing rules of the Epygi IP PBX used with the 
Auto Dialer.  Any header name can be used for the phone number column and the same name will 
be presented in the call to action when creating the scenario. 

If the scenario includes the play date and play time actions, the corresponding columns are also 
required in the calling list. The play date action uses the column containing the dates. The 
header name of that column is specified in the scenario, in play date action. The play time 
action uses the column containing the time of the day. The header name of that column is 
specified in the scenario, in play time action. 

If the scenario includes a menu that uses the Response Text then there will need to be 
appropriate columns in the calling list and the names of those columns should be specified in the 
Response Column fields of the menu options. For example on Figure 11, all menu options are 
using the same “Response” column of the calling list to register the response of the called party. 
The number of response columns in Calling List is not limited; every menu option may register the 
responses in a separate column of the calling list.  

The calling list may also include optional fields that are not utilized by the Auto Dialer but are 
good to have for user friendliness.  For example, Figure 6 includes the “Name” column containing 
the names of the called parties. The Quadro will not play these names. 
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There are also some auxiliary columns in the calling list that are being created by the Auto Dialer 
when importing (opening) the CSV file. The names of these columns have the “_” prefix to 
distinguish them from the columns created by the user. When saving the calling list, those 
auxiliary columns will be saved along with the data stored in the columns. These auxiliary columns 
will be blank initially and updated as the Auto Dialer runs. The auxiliary columns are as follows: 

_CallState column is used for tracking the call state in real time. The last state of the call 
stays in the calling list after the call is finished. 

_Status column is used for registering the status of the call after the called party’s input.  
The possible options are: “confirmed”, “cancelled” and “transferred”. The values in this 
column are used by Auto Dialer to make a decision about the necessity of making another 
call to a particular phone number. More specifically, if the value of this column for some 
phone number (calling list line) is “cancelled,” then the Auto Dialer may consider making 
another call attempt to that phone number. In the case of “confirmed” and “transferred,” the 
Auto Dialer will not make another attempt to call that phone number. 

_Attempts column keeps track of the number of call attempts to a specific phone number. 
Each time the call is cancelled by the called party or fails for another reason, the Auto Dialer 
will increase the number of attempts. Irrelevant to the value of _Status field, the Auto Dialer 
will stop calling a specific phone number if the value of _Attempts field equals Max retries 
count in configuration of the Auto Dialer. 

_Except column contains the checkboxes for disabling specific lines of the calling list. If the 
checkbox in some line is checked, then the Auto Dialer will not make a call to the phone 
number in that line when passing through the list. 

 

All fields of the Calling List except for auxiliary fields are editable for the user in real time (during active calling 
session).  

 

Making Calls 
 

To start the Auto Dialer (calling) session the following options are available: 

 

• Selecting the Dial -> Start menu command or corresponding button on the toolbar 
• Selecting the Dial -> Restart menu command or corresponding button on the toolbar 
• Selecting the Dial -> Start by schedule menu command or corresponding button on   

the toolbar 
 

 

Start Command 

 

If the Start command is the first command after the Auto Dialer’s launch, it will start making calls 
from the top of the calling list to the bottom until it reaches the last item on the list. During that 
process, the Auto Dialer populates the response and the auxiliary columns with the values 
indicating the user response, state and status of the call and the number of call attempts to the 
called number. When the first pass through the calling list is finished, the Auto Dialer starts the 
second pass from the top of the list.  
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The Auto Dialer will then only call numbers having the “cancelled” or “failed” status and the 
number of call attempts will be less than the Max retry count in Options configuration. If the 
calling process is not stopped by the user, the Auto Dialer will repeat the process until the list is 
completed. At this point, none of the entries in the calling list will have a status of “cancelled” or 
“failed” or the call attempt values will be equal to Max retry count. 

The Stop command during the active session will stop the calling process and the current state of 
the Auto Dialer will be saved so that with the next Start command, the Auto Dialer will continue 
calling from the state where it had been interrupted the previous time. 

If the Start command is the first command executed after the Auto Dialer launch, and the user 
response and auxiliary fields of the opened calling list are already populated by some values 
stored from previous sessions, then the command will take into account those values without 
resetting them.  

 

Restart Command 

 

Restart command acts similar to the Start command except before making calls it will reset the 
calling list, cleaning up the user response and auxiliary columns and starting the calling process 
from the beginning of the list.  

 

Start by Schedule Command 

 

Start by schedule command, similar to Restart command, cleans up the user response and the 
auxiliary columns of the calling list and starts calling from the beginning of the list at the point of 
time specified in the Schedule start time parameter in the Options. The calling session initiated 
by this command stops at the Schedule end time parameter in the Options unless the calling 
list is completed before that.  

If the calling session initiated by the Start by schedule command has been interrupted by the 
Stop command, the calling session will be stopped, no matter what time is specified in the 
Schedule end time parameter under Options. 

 

Stop Command 

 

Stop command stops the calling session, saving the current state of the calling list and current 
position of the dialer in the list. 
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THIS DOCUMENT IS PROVIDED TO YOU FOR INFORMATIONAL PURPOSES ONLY. The information 
furnished in this document, believed by Epygi Technologies to be accurate as of the date of publication, 
is subject to change without notice. Epygi Technologies assumes no responsibility for any errors or 
omissions in this document and shall have no obligation to you as a result of having made this 
document available to you or based upon the information it contains. 
 
Epygi is a registered trademark of Epygi Technologies, Ltd. All other products and services are the 
registered trademarks of their respective holders. 



Epygi Technologies Auto Dialer User’s Guide  
 

CONFIDENTIAL                    PAGE 18  16-Feb-12 
 
 

 
 

 
 
 

 
CCooppyyrriigghhtt  22000033  --  22001122  

EEppyyggii  TTeecchhnnoollooggiieess,,  LLttdd..  
AAllll  rriigghhttss  rreesseerrvveedd  


	Description
	Market
	Installation
	Configuration
	Configuring Connection with Epygi IP PBX
	Configuring the Calling Scenario
	Creating a New Calling Scenario
	Opening the Existing Calling Scenario

	Building the Calling List

	Making Calls
	Start Command
	Restart Command
	Start by Schedule Command
	Stop Command


